Hero image

Anforderungen für InstallAnywhere

In diesem Dokument finden Sie die technischen Daten für InstallAnywhere.


Für Systeme, auf denen InstallAnywhere ausgeführt wird (Autorenumgebung)

RAM 256 MB frei, vorzugsweise 512 MB
Freier Festplattenspeicherplatz 500 MB
Farbe High Color (Farbtiefe 16 Bit)
Auflösung Mindestens 1200 x 800

InstallAnywhere kann unter den neuesten Versionen der folgenden Betriebssysteme ausgeführt werden, die mit den aktuellen Patches und Servicepacks vollständig aktualisiert wurden.

Windows
  • Windows 10 (1903)
  • Windows Server 2008 R2, 2012, 2012 R2, 2016 und 2019(x64)
  • Windows 10 Fall Creators
  • Windows 10 Anniversary Update (x86 und x64)
  • Windows 7, 8.1 und 10 (x86 und x64)
  • Windows Vista
  • Windows Server 2008 (x86 und x64)

Windows-Zielsysteme müssen auch den SSE2-Anweisungssatz unterstützen.

Apple
  • Mac OS Catalina (10.15) mit Oracle Java 12
  • Mac OS Mojave (10.14) mit Oracle Java 8, 9, 10, 11 oder 12
  • Mac OS High Sierra (10.13.3) mit Java 7 oder 8
  • Mac OS Sierra (10.12) mit Oracle Java 7 oder 8
  • OS X El Capitan (10.11) mit Oracle Java 7 oder 8
Linux
  • Red Hat Enterprise Linux 7.2, 7.3, 7.4, 7.5, 7.6, 7.7 und 8 (x64)
  • Red Hat Enterprise Linux 7/7.1
  • Red Hat Enterprise Linux 6.x (Desktop und Server Edition; x86 und x64)
  • Red Hat Enterprise Linux 5.x (x86 und x64)
  • OpenSUSE Leap 42.3 (x64)
  • OpenSUSE Linux 13.2 und 15.1 (x64)
  • OpenSUSE Linux 11.x, 12.x und 13.1 (x86 und x64)
  • SUSE Linux Enterprise 11 (SP2 und SP3; x64), 12 (SP1, x64) und 15
  • Linux PPC 64 Bit (nur Build-Zeitpunkt) nur mit Java 6
  • Ubuntu 14.x, 15.04, 17.04, 17.10, 18.04, 18.04.2 und 19.04 (x64)
  • Ubuntu 13.x (Desktop und Server Edition, x86 und x64)
  • Ubuntu 10.x, 11.x und 12.x (x86 und x64)
  • Fedora 18, 19, 20, 24, 27, 28, 29 und 30 (Desktop Editions; x64)

Hinweis: Wenn Sie InstallAnywhere auf einem Linux-System installieren, wird bei der Installation versucht, einen symbolischen Link auf den standardmäßigen Linux-Loader (/lib/ld-linux.so.2) zu erstellen, sofern noch kein Link mit diesem Namen vorhanden ist. Der symbolische Link ist für die Anzeige der Host-ID im Host-ID-Dialogfeld und zudem für den Erfolg der Node-Locked-Lizenzierung notwendig. Der Link ist in Systemen vorhanden, die mit Linux Standard Base (LSB) 3 kompatibel sind, in nicht LSB-kompatiblen Systemen aber möglicherweise nicht. Weitere Informationen finden Sie in der Wissensdatenbank in Artikel Q209204.

Hinweis: Installer können auf beliebigen Plattformen für beliebige andere unterstützte Zielplattformen oder Sprachen erstellt werden. Die Lokalisierung für 32 Sprachen ist im Produkt enthalten.


Systemanforderungen für Docker-Images

Unterstützte Docker-Version
  • Docker 1.7.1
Plattform: Windows
  • Windows 7
Plattform: Linux
  • Ubuntu 14.10
  • Red Hat Enterprise Linux 7.1
  • CentOS 7.6
Plattform: Apple
  • OS X 10.8.x, 10.9.x und 10.10.3

Für Zielsysteme (Installer-Umgebung)

RAM 64 MB
Farbe High Color (Farbtiefe 16 Bit)
Auflösung Mindestens 640 x 480

Installer können in jeder beliebigen Version der folgenden Betriebssysteme ausgeführt werden, sofern diese Java 6, 7 oder 8 (bzw. Oracle Java 7 oder 8 für OS X) unterstützen. Von InstallAnywhere generierte Installer werden nur dann in Beta-Versionen oder in Vorabversionen unterstützt, wenn dies ausdrücklich erwähnt ist.

Windows
  • Windows 10 (1903)
  • Windows Server 2008 R2, 2012, 2012 R2, 2016 und 2019(x64)
  • Windows 10 Fall Creators
  • Windows 10 Anniversary Update (x86 und x64)
  • Windows 7, 8.1 und 10 (x86 und x64)
  • Windows 8 (x86 und x64)
  • Windows Vista (x86 und x64)
  • Windows Server 2008 (x86 und x64)

Windows-Zielsysteme müssen auch den SSE2-Anweisungssatz unterstützen.

Apple
  • Mac OS Catalina (10.15) mit Oracle Java 12
  • Mac OS Mojave (10.14) mit Oracle Java 8, 9, 10, 11 oder 12
  • Mac OS High Sierra (10.13.3) mit Oracle Java 7 oder 8, Mac OS Sierra (10.12) mit Oracle Java 7 oder 8
  • OS X El Capitan (10.11) mit Oracle Java 7 oder 81
Linux
  • CentOS 6.8, 7, 7.3, 7.4 und 7.6 (x86, x64)
  • Red Hat Enterprise Linux 7.2, 7.3, 7.4, 7.5, 7.6, 7.7 und 8 (x64)
  • Red Hat Enterprise Linux 7.2 for PowerPC (Little Endian)
  • Red Hat Enterprise Linux 7/7.1
  • Red Hat Linux 7.1 for PowerPC (Little Endian – nur Silent- und Konsolenmodus)
  • Red Hat Enterprise Linux 6.x, SUSE 11.x auf zSeries
  • Red Hat Enterprise Linux 6.x SUSE 11.x PPC 64 Bit (nur Build-Zeitpunkt) mit Java 6
  • Red Hat Enterprise Linux 6.x (Desktop und Server Edition; x86 und x64)
  • Red Hat Enterprise Linux 5 (x86, x64, Itanium 2 und AMD-64)
  • OpenSUSE Linux 13.2, 15.1 und 42.3 (x64)
  • OpenSUSE Linux 11.x, 12.x und 13.1 (x86 und x64)
  • SUSE Linux Enterprise 11 (SP2 und SP3; x64), 12 (SP1, x64)
  • Ubuntu 14.x, 15.04, 16.04 LTS, 17.10, 18.04, 18.04.2 und 19.04 (x64)
  • Ubuntu 13.x (Desktop und Server Edition, x86 und x64)
  • Ubuntu 9.x, 10.x, 11.x, 12.x (x86 und x64)
  • Fedora 18, 19, 20, 24, 27, 28, 29 und 30 (Desktop Editions; x64)
Solaris
  • Solaris 11 (x86 und SPARC)
  • Solaris 9, 10 (x86, SPARC und AMD-64)
HP-UX
  • HP-UX 11i (Itanium 2 und PA-RISC)
AIX
  • AIX 5.2, 5.3, 6.1 und 7.1 (Power/PowerPC)
IBM
  • i5/OS (OS/400) auf System i – V5R3 und V5R4 (nur Enterprise Edition), IBM i 6.1 und IBM i 7.1
  • z/OS
Sonstige
  • FreeBSD
  • Andere Linux- und Unix-basierte Betriebssysteme (POSIX-kompatible Shell erforderlich)

Unterstützte Java Virtual Machines

InstallAnywhere unterstützt die folgenden Java Virtual Machines:

VM Unterstützte Versionen
IBM 1.7.x, 1.8.x, 9
HP 1.7.x, 1.8.x, 9
Sun/Oracle 1.7.x, 1.8.x, 9, 10, 11, 12
OpenJDK 1.7.x, 1.8.x, 9, 11, 12
Amazon Corretto 8, 11

Der plattformübergreifende Installer InstallAnywhere installiert JRE 1.7.0_60-VM-Pakete. Es kann eine beliebige Java Virtual Machine mit dem Installer gebündelt werden, damit sichergestellt wird, dass das Zielsystem die Mindestanforderungen für die Installer und die Anwendungen erfüllt. Sie können weitere JRE-VM-Pakete herunterladen.

Von InstallAnywhere generierte Multiplattform-Installer werden nicht von Beta- oder Vorabversionen von Java unterstützt.


Voraussetzungen für virtuelle Appliances

Systemanforderungen zum Erstellen und automatischen Bereitstellen virtueller Appliances

In der nachstehenden Tabelle sind Systemanforderungen zum Erstellen und automatischen Bereitstellen virtueller Appliances in InstallAnywhere beschrieben.

Hypervisor Anforderungen
VMware vSphere 5/vCenter
  • Anmeldeinformationen für einen VMware vSphere 5-Server
  • Wenn Ihr VMware vSphere 5-Server von einem VMware vCenter 5-Server verwaltet wird, benötigen Sie auch die Anmeldeinformationen für den VMware vCenter-Server.
  • Anmeldeinformationen für Hostcomputer (Anmeldeinformationen für physische Computer/Virtual Machines, die stark dem Betriebssystem der virtuellen Appliance ähneln)
Amazon EC2
  • Anmeldeinformationen für Amazon EC2 (Kontonummer, Zugriffsschlüssel, geheimer Zugriffsschlüssel, X.509-Zertifikat und privater Schlüssel für Ihr Amazon EC2-Konto)
  • Anmeldeinformationen für Hostcomputer (Anmeldeinformationen für physische Computer/Virtual Machines, die stark dem Betriebssystem der virtuellen Appliance ähneln)

Unterstützte Hypervisoren und Plattformen für Virtual Appliances

InstallAnywhere unterstützt die Erstellung virtueller Appliances, die unter VMware vSphere 5- und Amazon EC2-Hypervisoren ausgeführt werden. Virtual Appliances unter VMware vSphere 5 können auf lizenzierten VMware vSphere 5-Servern (Standalone) oder auf lizenzierten VMware vSphere 5-Servern bereitgestellt werden, die von einem lizenzierten VMware vCenter 5-Server verwaltet werden

In der folgenden Tabelle sind die Betriebssysteme genannt, die unter den unterstützten Hypervisoren unterstützt werden.

Unterstützter Hypervisor Unterstützte Betriebssysteme
VMware vSphere 5/vCenter
  • CentOS 7, 6.2 und 6.3 (x86 und x64)
  • OpenSUSE 12.2 (x86 und x64) und SUSE Linux Enterprise Server 11 SP2 – erfordert die Verwendung einer bereits vorhandenen SUSE-VM oder eines entsprechenden Snapshots (keine Unterstützung für Verwendung einer Vorlage für virtuelle Appliances der SUSE-VM)
  • Red Hat Enterprise Linux 6.4 (x86 und x64) – erfordert die Verwendung eines Red Hat-Netzwerks – registrierte Vorlage für virtuelle Appliances der RHEL-VM
  • Red Hat Enterprise Linux 6.3 (x64) – erfordert die Verwendung eines Red Hat-Netzwerks – registrierte Vorlage für virtuelle Appliances der RHEL-VM
  • Ubuntu 11.10, 12.04, 12.1 und 13.04 (x86 und x64)
Amazon EC2
  • Ubuntu 11.10 und 12.04 (x32)

Zum Erstellen virtueller Appliances muss InstallAnywhere mit JRE 1.7 oder 1.8 gestartet werden.


 

Unsere Website benutzt Cookies, um Ihre bevorzugten Einstellungen zu speichern und Ihre Navigation zu optimieren. Wenn Sie diese Nachricht schließen oder auf der Website navigieren, stimmen Sie unseren Cookie-Richtlinien zu. OK, verstanden OK, verstanden