New Version 2016
InstallShield: Anforderungen

So werden weltweit MSI- und EXE-Installer sowie UWP- und WSA-Pakete für Windows-Anwendungen erstellt

Anforderungen

Systemanforderungen für InstallShield® 2016

InstallShield ist die führende Softwareinstallationslösung für die Entwicklung von App-V-Paketen und MSI-Installern für Windows-Anwendungen. Im Folgenden sind die Mindestanforderungen für Systeme aufgeführt, in denen InstallShield ausgeführt wird (Erstellungsumgebung), sowie für Zielsysteme, in denen die mit InstallShield erstellten Installationen ausgeführt werden (Laufzeitumgebung).

Systeme mit InstallShield

Processor Pentium III-PC (500 MHz oder mehr empfohlen)
RAM 256 MB RAM (512 MB empfohlen)
Festplatte 500 MB freier Speicherplatz
Anzeige Entwickelt für XGA-Auflösung mit 1024 × 768 oder höher
Betriebssystem

Windows Vista
Windows Server 2008 
Windows 7
Windows Server 2008 R2
Windows 8
Windows Server 2012
Windows 8.1
Windows Server 2012 R2
Windows 10
Windows Server 2016

Rechte Administratorrechte auf dem System
Maus Microsoft IntelliMouse oder kompatibles Zeigegerät
Integration mit Visual Studio optional verfügbar

Die folgenden Versionen von Microsoft Visual Studio können mit InstallShield Premier Edition oder Professional Edition integriert werden:

  • Visual Studio 2008
  • Visual Studio 2010
  • Visual Studio 2012
  • Visual Studio 2013
  • Visual Studio 2015
  • Visual Studio 2017

Die folgenden Editionen dieser Versionen von Visual Studio können mit InstallShield Premier Edition oder Professional Edition integriert werden:

  • Community
  • Professional
  • Premium
  • Ultimate

Für Zielsysteme

Hinweis: Bei allen Projekttypen mit Ausnahme von Suites (Projekttypen Advanced UI und Suite/Advanced UI) muss mindestens Windows XP SP3 oder Windows Server 2003 SP2 auf den Zielsystemen installiert sein, auf denen die in InstallShield erstellen Installationen ausgeführt werden. Bei Suites muss auf den Zielsystemen mindestens Windows Vista oder Windows Server 2008 installiert sein.

Zielsysteme müssen folgende Betriebssystem-Mindestanforderungen erfüllen:

  • Windows XP SP3
  • Windows Server 2003 SP2
  • Windows Vista
  • Windows Server 2008
  • Windows 7
  • Windows Server 2008 R2
  • Windows 8
  • Windows Server 2012
  • Windows 8.1
  • Windows Server 2012 R2
  • Windows 10
  • Windows Server 2016

Die Zielsysteme müssen auch den SSE2-Anweisungssatz unterstützen.

Zurück nach InstallShield